Specify version of all used Maven plugins

Description

Building with Maven 3.0-beta-1 gives notice about unspecified plugin versions. For example (top level):

[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.codehaus.cargo:cargo-trunksom:1
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-compiler-plugin is missing. @
[WARNING] 'reporting.plugins.plugin.version' for org.apache.maven.plugins:maven-javadoc-plugin is missing. @
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING]

Version of all used plugins should be specified to ensure build reproducibility.

Status

Assignee

Anders Hammar

Reporter

Anders Hammar

Components

Fix versions

Affects versions

1.0.1

Priority

Major
Configure