Goal deploy:start wait tomcat despite of <wait>false</wait>

Description

Hi,

I use cargo to start an existing tomcat6x with the configuration below. I set the wait property to false. The plugin still waiting the container. This behavior don't happen if i set the container to standalone.

Is it a bug or a configuration probleme?
Thank you

<build>
<plugins>
<plugin>
<groupId>org.codehaus.cargo</groupId>
<artifactId>cargo-maven2-plugin</artifactId>
<version>1.0</version>
<configuration>
<wait>false</wait>
<container>
<containerId>${container.id}</containerId>
<zipUrlInstaller>
<url>http://mir2.ovh.net/ftp.apache.org/dist/tomcat/tomcat-6/v6.0.24/bin/apache-tomcat-6.0.24.zip</url>
<installDir>${container.install.dir}</installDir>
</zipUrlInstaller>
</container>
<configuration>
<type>existing</type>
<home>${project.build.directory}/${container.name}/</home>
<properties>
<cargo.servlet.port>${servlet.port}</cargo.servlet.port>
</properties>
</configuration>
<deployer>
<type>installed</type>
<deployables>
<deployable>
<groupId>${project.groupId}</groupId>
<artifactId>${project.artifactId}</artifactId>
<type>${project.packaging}</type>
<properties>
<context>${project.artifactId}</context>
</properties>
</deployable>
</deployables>
</deployer>
</configuration>
<executions>
<execution>
<id>install</id>
<phase>generate-resources</phase>
<goals>
<goal>install</goal>
</goals>
</execution>
<execution>
<id>start-container</id>
<phase>pre-integration-test</phase>
<goals>
<goal>start</goal>
</goals>
<configuration>
<wait>false</wait>
</configuration>
</execution>
<execution>
<id>stop-container</id>
<phase>post-integration-test</phase>
<goals>
<goal>stop</goal>
</goals>
</execution>
</executions>
</plugin>
</plugins>
</build>

Status

Assignee

Unassigned

Reporter

Didier Bathily

Components

Fix versions

Affects versions

1.0-maven2

Priority

Major
Configure