Uploaded image for project: 'Codehaus Cargo'
  1. CARGO-515

Problem with resolving ${version} property in pom.xml files

    Details

    • Type: Bug
    • Status: Closed (View workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects versions: None
    • Fix versions: 1.0
    • Components: Maven2/Maven3
    • Labels:
      None

      Description

      When I execute integration tests using cargo I got following message:

      Missing:
      ----------
      1) org.codehaus.cargo:cargo-core-api-module:jar:2.4.1

      I don't know why 2.4.1 version was resolved. I haven't found any artifact with 2.4.1 version in local repository.

      When I change all $

      {version} properties in cargo-core-api-module and cargo-core-api-container pom to fixed value "0.9", all dependencies are resolved correctly. I know that is a problem with maven version resolving mechanism, but maybe You can change ${version}

      property to something more unique for cargo project?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              marcinkuthan Marcin Kuthan (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: