Uploaded image for project: 'Codehaus Cargo'
  1. CARGO-360

Latest maven-surefire-plugin has a bug, version 2.1.3 should be used

    Details

    • Type: Bug
    • Status: Closed (View workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects versions: 0.9
    • Fix versions: 0.9
    • Components: Build
    • Labels:
      None
    • Environment:

      Linux debian 2.6.17 #1 Thu Jun 22 15:38:49 CEST 2006 i686 GNU/Linux

      Description

      vmassol has changed the sample/pom.xml because the maven-surefire-plugin has a bug:
      <artifactId>maven-surefire-plugin</artifactId>
      <!-- TODO: Version 2.2 of the surefire plugin is broken.
      See http://jira.codehaus.org/browse/MSUREFIRE-145. Once it's fixed we'll be able
      to remove this version element -->
      <version>2.1.3</version>

      It still doesn't built because the main pom.xml pulls the maven-surefire-plugin 2.2.
      the patch change the main pom.xml the same way vmassol has changed sample/pom.xml

        Attachments

          Activity

            People

            • Assignee:
              vincentmassol Vincent Massol (Inactive)
              Reporter:
              alexandrerussel Alexandre Russel (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: