Details

    • Type: Bug
    • Status: Closed (View workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects versions: 1.2.2
    • Fix versions: 1.2.3
    • Components: None
    • Labels:
      None
    • Environment:

      Windows7, WindowsXP, Maven-3.0.3

      Description

      Hi,

      when running cargo:redeploy targeting a remote container that is outside my network, cargo cannot resolve the host.

      Failed to redeploy:
      caused by: java.net.UnknownHostException: myserver.uk

      It seems cargo ignores the proxy settings, either specified in settings.xml or passed via command line arguments -Dhttp.proxyHost etc. (which I find quite strange, since that should not happen, right?)

      It think this problem might be associated to issues CARGO-517 Closed and CARGO-1042 Closed .

      When I switch back to version 1.2.1 this problem does not occur. Here, cargo can connect to the server. In 1.2.1 however, CARGO-1042 Closed blocks my work.

      I've attached

      • the full log to my command: mvn -s settings.xml cargo:redeploy -X -e -DskipTests -Dhttp.proxyHost=proxy -Dhttp.proxyPort=8080
      • the settings.xml I use.
      • a minimal example test case project, where I only anonymized server names and credentials.

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                Savas Ali Tokmen (Inactive)
                Reporter:
                Robert (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: