Uploaded image for project: 'Codehaus Cargo'
  1. Codehaus Cargo
  2. CARGO-1102

jboss42x remote deploy failure: pointing to wrong war filename?

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.1
    • Fix Version/s: None
    • Component/s: JBoss, Maven2/Maven3
    • Labels:
      None
    • Environment:

      Mac 10.6.8, Ubuntu 11.10

      Description

      I only see failure when I'm trying to remote deploy to a JBoss 4.2.3 GA instance. I've ensured the servers can speak to each other, and I've manually placed a war on the deploying server's normal (port 80) webserver and manually crafted the URL the Cargo makes to hit it, and that works fine, too. So all connectivity seems fine.

      The only things that seems to me to be wrong is that the filename in the URL in the example at http://cargo.codehaus.org/JBoss+Remote+Deployer#JBossRemoteDeployer-JBoss40xand42x contains "-1.0-SNAPSHOT" and even though I am trying to deploy a snapshot, too, I only have "fly-garmin.war" with no version or "-SHAPSHOT".

      Here is what I have in my POM...

      <plugin>
      <groupId>org.codehaus.cargo</groupId>
      <artifactId>cargo-maven2-plugin</artifactId>
      <version>1.2.1</version>
      <configuration>
      <container>
      <containerId>jboss42x</containerId>
      <type>remote</type>
      </container>
      <configuration>
      <type>runtime</type>
      <properties>
      <cargo.remote.username>foo</cargo.remote.username>
      <cargo.remote.password>bar</cargo.remote.password>
      <cargo.hostname>dflyproxy.garmin.com</cargo.hostname>
      <cargo.servlet.port>80</cargo.servlet.port>
      <cargo.jboss.remotedeploy.port>8980</cargo.jboss.remotedeploy.port>
      <cargo.logging>high</cargo.logging>
      </properties>
      </configuration>
      </configuration>
      <executions>
      <execution>
      <id>start-container</id>
      <phase>pre-integration-test</phase>
      <goals>
      <goal>deploy</goal>
      </goals>
      </execution>
      </executions>
      </plugin>
      

        Gliffy Diagrams

          Activity

          savasalitokmen Savas Ali Tokmen added a comment -

          Hi KenOK, I would then propose to close this ticket as "Cannot reproduce", and if you want add a note in the JBoss remote deployer's documentation.Agree?Cheers

          kenmartin Ken Martin added a comment -

          Well, I suppose we could, but that means this really doesn't work for continuous integration, which is what we'd like to be doing with it.Is there anything I can do to better log what's happening with SimpleFileServer? If it has errors, where might they be written to?

          savasalitokmen Savas Ali Tokmen added a comment -

          Hi KenFor the ports, you can use the org.codehaus.mojo:build-helper-maven-plugin's reserve-network-port goal; this way it will always reserve some unused ports. Example: http://svn.codehaus.org/cargo/extensions/trunk/maven2/samples/pom.xmlElse, if you run mvn with the -X option, you will see the log messages listed in: http://svn.codehaus.org/cargo/core/trunk/containers/jboss/src/main/java/org/codehaus/cargo/container/jboss/internal/SimpleHttpFileServer.javaCheers

          savasalitokmen Savas Ali Tokmen added a comment -

          Hi KenAny news?Cheers

          savasalitokmen Savas Ali Tokmen added a comment -

          Issue cannot be reproduced when org.codehaus.mojo:build-helper-maven-plugin's reserve-network-port goal is used (i.e., reserved unused ports are always used).Example: http://svn.codehaus.org/cargo/extensions/trunk/maven2/samples/pom.xml


            People

            • Assignee:
              Unassigned
              Reporter:
              kenmartin Ken Martin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: