Uploaded image for project: 'Codehaus Cargo'
  1. CARGO-1041

Deployment of a WAR with a subcontext does not work anymore in Tomcat

    Details

    • Type: Bug
    • Status: Closed (View workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects versions: 1.1.2
    • Fix versions: 1.1.3
    • Components: Tomcat
    • Labels:
      None

      Description

      See: http://cargo.markmail.org/message/djbydzdoubvew2wj?q=list:org%2Ecodehaus%2Ecargo%2Euser

      Hi all,

      my application has to be deployed with an subcontext. So far i use version 1.0.5 and this works fine.

      <deployable type="war" file="base#sub.war" />
      

      This is more or less what you usually do if you like have a context url like
      http://myserver.com/base/sub/index.html

      This works fine with 1.0.5 but stops working with 1.1.0 and 1.1.1.
      I have also tried

      <deployable type="war" file="ci.war">
      <property name="context" value="base/sub"/>
      </deployable>
      

      or

      <deployable type="war" file="ci.war">
      <property name="context" value="base#sub"/>
      </deployable>
      

      both results in an directory base under webapps and an file sub.war inside. The war is not extracted.

      Any idea how to get the subcontext back.

      Thanks

        Attachments

          Activity

            People

            • Assignee:
              Savas Ali Tokmen (Inactive)
              Reporter:
              Savas Ali Tokmen (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: